
Connect a Microsoft Sidewinder Precision 2 Joystick to 

SeligSIM 

This guide lets you use SeligSIM with a common joystick that works with a PC. The instructions here are for 

the Microsoft Sidewinder Precision 2 Joystick. The Joystick has a self centering 3-axis joystick and a rotating 

non-centering throttle slider. On top of the joystick there is an 8-way hat switch, a trigger switch and 3 push 

buttons labeled 2, 3 and 4. On the base there are four face buttons in a diamond shape (labeled 5, 6, 7 & 8),  

RC transmitters often have a mix of two-position and three-position switches that keep their position when 

moved. These do things like, e.g., moving retractable landing gear up/down. Because this joystick does not have 

switches, the steps below imitate RC transmitter switches by using the buttons on the joystick. When you press 

a button, it changes the “position of the switch.” That switch position does not change when you release the 

button. It will change when you press a different button related to that function, i.e. two buttons will control 

landing gear up/down. Further, three buttons will control flaps, two buttons will control the resets, and three 

buttons will set the flight mode. 

  



This guide gives instructions for setups as shown in the table below. The first setup (“4 Ch”) maps only the 

joystick and throttle slider and should be applicable to nearly any joystick. Although the axes for the controls 

might be slightly different than given in the table for the Sidewinder joystick, the controller aileron axis will 

always be mapped to vJoy axis 8, elevator to vJoy axis 7, rudder to vJoy axis 6, and throttle to vJoy axis 5 as 

required by SeligSIM (per last column in the table and described previously). 

For the “4 Ch” case, the keyboard is used for the remaining controls that are not remapped. Keys 1/2/3 control 

the three flight modes. Gear is usually on key 6. Flaps are on keys 4/5 and offer two flap settings (half and full). 

The keys work as toggles, i.e. press once to put flaps down, and press again to retract the flaps. Reset is done 

using the keys: Spacebar (Reset-To-Home) and U (Reset-In-Place). 

The “8 Ch” case maps everything (using all 8 vJoy axes). 

With your finished remapping, Joystick Gremlin forwards your control inputs to vJoy which is what you will 

select as your USB interface in SeligSIM 2024b. 

Sidewinder Joystick  

Control Inputs 

Axes/Buttons SeligSIM Function 4 Ch 8 Ch vJoy Axis 

mapping 

Joystick Left-Right X Axis Ailerons x x 8 

Joystick Fore-aft Y Axis Elevator x x 7 

Joystick Rotation Z Rotation Rudder x x 6 

Throttle slider Slider Throttle x x 5 

Joystick left button Button 3 Gear - Up  x 4 

Joystick right button Button 4 Gear - Down 

Base button 5 Button 5 Flaps - Up  x 3 

Base button 6 Button 6 Flaps – 50% 

Base button 7 Button 7 Flaps - Full 

Trigger button 1 Button 1 Reset-to-Home  x 2 

Joystick button 2 Button 2 Flight Mode - Low  x 1 

Base button 8 Button 8 Flight Mode - Medium 

Hat Hat Flight Mode - High 

Calibrating the 4 Ch Setup with No Controls for Gear, Flaps, Resets, and Flight Modes 

When calibrating inside SeligSIM with the “4 Ch” setups where nothing is being mapped to the last four 

functions, SeligSIM will ask for you to move those controls. Skip them, and the respective axis in SeligSIM 

will not be used. You will use the keyboard keys for those controls not commanded by your joystick controller. 

  

https://www.seligsim.com/manual/getting_started.html#standard-axes-order


Prerequisites 

If you have already installed vJoy, installed Joystick Gremlin, and made a virtual joystick, then skip the block 

below and start with the following section. 

Install vJoy 

This makes a virtual joystick for SeligSIM (or for anything else). 

 Unplug all USB gamepads, joysticks, TacCon, and other “R/C” controllers. 

 Download and run vJoySetup.exe. This downloads from github. 

Install Joystick Gremlin 

This configures what vJoy makes. 

 Download and run Joystick.Gremlin.R13.3.msi. This downloads from the developer. 

 Reboot. 

Verify Installations 

Verify that both vJoy and Joystick Gremlin appear in the Windows Start menu. 

Make a vJoy Virtual Joystick 

 From the Start menu, Configure vJoy. This launches vJoyConf. 

 At bottom left, check the checkbox Enable vJoy. 

 You might need to click Add Device, reboot, and once more Start -> vJoy -> Configure vJoy. 

 Check all 8 checkboxes for Axes. 

 Note: Even if you are going to use less than 8 axes, still check all to make vJoy have: 8 axes. 

 Set Number of Buttons to 0. 

 Set POVs to 0. 

 Uncheck the checkbox Enable Effects. 

 Click Apply . Your computer may beep. 

 vJoyConf can be closed. 

 Reboot, if prompted by vJoyConf. 

 Open the Windows Game Controller to see virtual joystick named vJoy Device. 

 You set up vJoy (image below) one time. This completes your vJoy Device setup. 

https://www.seligsim.com/manual/controllers/howto-gamepad.html#gamepad-connection
https://github.com/jshafer817/vJoy/releases/tag/v2.1.9.1
https://whitemagic.github.io/JoystickGremlin/download
https://www.seligsim.com/manual/getting_started.html#controller


 

vJoyConf configuring a virtual joystick with 8 axes, 0 buttons, and 0 hat switches.  

This is vJoy Device #1 indicated by the light green tab labeled “1”. 

Remaining Instructions 

 The remainder of these instructions covers using Joystick Gremlin to remap your controller 

inputs to vJoy. 

Connect the Sidewinder Precision 2 Joystick 

Connect your joystick. The Sidewinder Precision 2 Joystick has the controls shown below in the Windows 

Game Controller gadget. 

 



Calibrate the Sidewinder Precision 2 Joystick using Joystick Gremlin 

 Disconnect other USB controllers. 

 Plug the joystick into the PC. 

 Run the Windows Game Controller gadget (above) to confirm your controls. 

 From the Windows Start menu, run Joystick Gremlin (hereafter called JG). 

 Create a new Profile in JG. From the JG’s menu, choose File -> New Profile. 

 From JG’s menu, choose Tools -> Calibration. A calibration window appears. 

 From top dropdown, choose the name of the controller “Sidewinder Precision 2 Joystick” (if not already 

chosen). 

 Move the sticks over their full ranges. 

 Release the sticks so that they center. Click on Centered. Click on Save. Click on Close.  

 

View the Controller Inputs and Remapping 

 From JG’s menu, choose Tools -> Input Viewer .  

A new window appears (hereafter called JG-viewer). Make it tall as shown below. 

 In the JG-viewer window, for the Sidewinder Precision 2 Joystick, check the two boxes:  

Axes - Current and Buttons + Hats. 

 For the vJoy Device #1 , check the box: Axes - Current . SeligSIM will only use vJoy axes. 

 Move the sticks and press the buttons (not the mode button, however) to see that your inputs are being 

seen by JG. All controls in the table above should be active (table column: “Logitech Axes/Buttons”). 

 The vJoy Device #1 axes will not move because you have yet to define the remapping. 

 See image below. 

https://www.seligsim.com/manual/getting_started.html#selecting-your-controller


 

JG-viewer  
JG input/output viewer showing the axes and buttons for the joystick controller and vJoy Device. 

Remap the Sidewinder Precision 2 Joystick 

JG’s top row has tabs for USB controllers, your keyboard, and the vJoy Device #1 that you created. 

Generally, the USB controllers are the inputs to the output that is the virtual joystick vJoy Device #1 which is 

used by SeligSIM. The keyboard appears, but it will not be used here. Other USB controllers will appear if you 

have others plugged into your computer. Disconnect any extraneous USB controllers for this setup. 

When you are finished remapping, follow these steps to use the controller: 

 In Joystick Gremlin, click the gamepad icon to change it from black to green so that Joystick Gremlin is 

Activated. Use JG’s Tools -> Input Viewer to confirm that your inputs are going to the vJoy Device 

joystick as you expect. 

 When running SeligSIM, select the vJoy Device virtual joystick that you created. Do not select the 

Sidewinder Precision 2 Joystick  



DOWNLOAD: Preconfigured Mapping File 

Instead of manually doing all the steps on the rest of this page, you may instead take a shortcut if you are using 

the: Sidewinder Precision 2 Joystick. 

 Right click to download and save the JG Profile (file) sidewinder.xml to your computer. 

 From JG’s menu, choose File -> Load Profile and choose that file. 

 When you open it, JG may ask you “The profile has been modified. Do you want to save your changes?” 

You can click “discard”, and what you were doing prior will not be saved. 

 Now from the JG menu, click on Actions, then Swap Devices. In the popup, click on the Sidewinder 

Precision 2 Joystick, and it will ask: “Please press the desired …”. Just move the joystick and the 

prompt will close. Then click X to close the Swap Devices popup. Now move the sticks around and the 

remapping functions in the downloaded Profile will appear on the right side panel. 

 It is suggested that you step through remapping instructions below (follow along) to understand how the 

remapping works. Also, you will see how the Sidewinder Precision 2 Joystick inputs are used by 

SeligSIM (via vJoy axes). 

 Save the Profile. It will save to the location where you loaded it. But if you select  

File -> Save Profile As (recommended), then it will save it to your local files location 

(Owner/joystick gremlin) or a location you choose. 

 You can confirm your final controls setup below. 

Note 

When loading in a new Profile, it is a known that Joystick Gremlin will discard the Action Description names, 

e.g. “Ailerons”, and so on. The names are not necessary. But you can follow along below and add back in the 

names and save your Profile. 

Tip 

To use the controller, follow these steps: 

 In Joystick Gremlin, click the gamepad icon to change it from black to green so that Joystick Gremlin is 

Activated. Use JG’s Tools -> Input Viewer to confirm that your inputs are going to the vJoy Device 

joystick as you expect (following the table above showing how your inputs remap to the specific vJoy 

axes). 

 When running SeligSIM, select the vJoy Device virtual joystick that you created. Do not select the 

Sidewinder Precision 2 Joystick. 

 See the section on calibrating in SeligSIM. Some very specific steps are require when calibrating the 

joystick. 

Overview 

Each section below remaps a single control (or controls) to one axis for SeligSIM, starting with Ailerons. First, 

you move a control to select an input. It will gray highlight on the left side of JG’s main window. Then you will 

define where that control is mapped using the right side of JG main window. Then you can test each axis 

mapping with the JG-viewer window to see that it is correct. 

  

https://www.seligsim.com/manual/_downloads/d299f2a13ca4a7d58e2f509791c58749/gamepad.xml
https://www.seligsim.com/manual/controllers/howto-gamepad.html#confirm-the-remapping


Remap the Sidewinder Precision 2 Joystick Axes to vJoy Axes: 4 Ch 

If you are using the downloaded setup above, you do not need to carryout these steps below. 

To create your remapping to the standard axes order for SeligSIM, these steps are performed in JG’s main 

window. To start, the JG gamepad icon should be black (not green). If it is green, click on it. 

In JG’s main window, click on the tab: SideWinder Precision 2 Joystick. 

 The left side of the window lists the joystick axes and buttons. 

 The last moved axis or button will be highlighted gray. 

 The right side shows what each axis and button does (what will define the remapping). 

 This right side is initially blank. 

 The left side’s labels for the axes (e.g., X Axis, and so on) are the Windows terminology for joystick 

axes and buttons and not meaningful to SeligSIM. Yet, the left side names will be used in the 

instructions here. 

Map the Aileron Joystick (Axis 1) to vJoy Axis 8 

 First you may need to move the joystick around to ‘wake-up’ the main JG window. It can go into a 

“sleep” mode. Again, the last moved axis or button should highlight gray as you move each control 

input. 

 Move the aileron joystick left to right.  

In JG, the left side’s highlight jumps to X Axis. 

 On the right side, into Action Description type “Ailerons”. 

 On the right side, next to the first dropdown (it will have Remap selected), click Add. 

 Inside the gray Remap box, change the lower dropdown from X Axis to Dial (vJoy Axis 8). 

 See image below. Click to enlarge. 

Test your mapping: 

 At top left, click the JG gamepad icon (“Activate”) to change it from black to green. 

 Move the aileron stick. Now JG-viewer’s vJoy Axis 8 reacts to that movement. 

 Your first axis remapping is complete. 

 Click the JG gamepad icon to make it black again. 

This screen shot below also shows results of the remaining instructions.  

https://www.seligsim.com/manual/getting_started.html#standard-axes-order


 

Map the Elevator Joystick (Axis2) to vJoy Axis 7 

 Move the joystick fore and aft. The left side’s highlight jumps to Y axis. 

 On the right side, into Action Description type “Elevator”. 

 On the right side, next to Remap, click Add. 

 Inside the gray Remap box, change the lower dropdown to Slider (vJoy Axis 7). 

 Click the JG gamepad icon green. 

 Move the elevator stick. Now JG-viewer’s vJoy Axis 7 reacts to that movement. 

 Click the JG gamepad icon to make it black again. 

Map the Rudder Joystick (Axis 3) to vJoy Axis 6 

 Rotate the joystick. The left side’s highlight jumps to Z rotations. 

 On the right side, into Action Description type “Rudder”. 

 On the right side, next to Remap, click Add. 

 Inside the gray Remap box, change the lower dropdown to Z Rotation (vJoy Axis 6). 

 Below the Remap box, change the dropdown Remap to Response Curve. Click Add. 

 Within the Response Curve box, click on Invert to reverse the axis. 



Map the Throttle Slider to vJoy Axis 5 

 Rotate the throttle slider. The left side’s highlight jumps to Slider. 

 On the right side, into Action Description type “Throttle”. 

 On the right side, next to Remap, click Add. 

 Inside the gray Remap box, change the lower dropdown to Y Rotation (vJoy Axis 5). 

 Below the Remap box, change the dropdown Remap to Response Curve. Click Add. 

 Your result should match the image below. 

 



 

This completes the “4 Ch” setup and only uses the joysticks. You could stop here if you want to test out your 

controller in SeligSIM before adding more channel remapping. 

Save Your Work 

From the menu, File -> Save Profile As and give it a name, e.g. Sidewinder.xml .  

After you have saved it once, you can File -> Save Profile at any time, of course. 

Activate and Test 

When the JG gamepad icon is green, the JG-viewer window should show vJoy axes 5/6/7/8 reacting to your 

joystick controls defined above. When the sticks are pushed all the way to the lower left, the axes should appear 

as shown below. Axes 1/2/3/4 will be in the middle and not move. If your controller is different and an axis is 

reversed, then add a Response Curve -> Invert to that axis, save, and test (e.g., see rudder axis invert steps 

above). 

 

JG-viewer  
JG input/output viewer showing the axes and buttons for the Sidewinder Precision 2 Joystick controller and 

vJoy Device. (4 Ch setup) 

  



Remap the Joystick Axes to vJoy Axes: 8 Ch 

(Adding four more axes) 

To the “4 Ch” above, continue and add the remaining axes to finish the “8 Ch” setup. 

Begin by saving your file using File -> Save Profile As and give it a name, e.g. Sidewinder.xml. 

The following steps map 8 buttons and the Hat to create the remaining 4 vJoy axes. The basic operations of 

each step are nearly the same. Nevertheless, each step is given in detail. 

If the gamepad icon is green, click it to make it black. 

Map the Gear Buttons to vJoy Axis 4 

 Press the joystick top left button 3. The left side’s highlight jumps to Button 3. 

 On the right side, into Action Description type “Gear - Up”. 

 On the right side, change the dropdown from Remap to Macro. Click Add. 

 Inside the newly added gray Macro box: 

o In the column of icons, click the top icon. 

o Inside the right side’s Action Settings do the following: 

o Change the dropdown from Pause to vJoy. 

o Below the new dropdown vJoy Device 1, change the dropdown to X Rotation (vJoy Axis 4). 

o Leave the Absolute button checked, not the Relative one. 

o Arrow up to the value: 1.000. 

 Press the joystick top right button 4. The left side’s highlight jumps to Button 4. 

 On the right side, into Action Description type “Gear - Down”. 

 On the right side, change the dropdown from Remap to Macro. Click Add. 

 Inside the newly added gray Macro box: 

o In the column of icons, click the top icon. 

o Inside the right side’s Action Settings do the following: 

o Change the dropdown from Pause to vJoy. 

o Below the new dropdown vJoy Device 1, change the dropdown to X Rotation (vJoy Axis 4). 

o Leave the Absolute button checked, not the Relative one. 

o Arrow down to the value: -1.000. 

Map the Flap Buttons to vJoy Axis 3 

 Press the joystick base button 5. The left side’s highlight jumps to Button 5. 

 On the right side, into Action Description type “Flaps - Up”. 

 On the right side, change the dropdown from Remap to Macro. Click Add. 

 Inside the newly added gray Macro box: 

o In the column of icons, click the top icon. 

o Inside the right side’s Action Settings do the following: 

o Change the dropdown from Pause to vJoy. 

o Below the new dropdown vJoy Device 1, change the blank dropdown to Z Axis (vJoy Axis 3). 

o Leave the Absolute button checked, not the Relative one. 

o Arrow down to the value: -1.000. 

o At right, change from the sideways Action tab to the Virtual Button tab. 

o Click all virtual button boxes. 

 Press the joystick base button 6. The left side’s highlight jumps to Button 6. 



 On the right side, into Action Description type “Flaps - Half”. 

 On the right side, change the dropdown from Remap to Macro. Click Add. 

 Inside the newly added gray Macro box: 

o In the column of icons, click the top icon. 

o Inside the right side’s Action Settings do the following: 

o Change the dropdown from Pause to vJoy. 

o Below the new dropdown vJoy Device 1, change the blank dropdown to Z Axis (vJoy Axis 3). 

o Leave the Absolute button checked, not the Relative one. 

o Leave the value as: 0.000. 

 Press the joystick base button 7. The left side’s highlight jumps to Button 7. 

 On the right side, into Action Description type “Flaps - Full”. 

 On the right side, change the dropdown from Remap to Macro. Click Add. 

 Inside the newly added gray Macro box: 

o In the column of icons, click the top icon. 

o Inside the right side’s Action Settings do the following: 

o Change the dropdown from Pause to vJoy. 

o Below the new dropdown vJoy Device 1, change the blank dropdown to Z Axis (vJoy Axis 3). 

o Leave the Absolute button checked, not the Relative one. 

o Arrow up to the value: 1.000. 

Map the Reset-To-Home Button to vJoy Axis 2 

 Press the “Trigger” button 1 which is at the front of the Joystick. The left side’s highlight jumps to 

Button 1. 

 On the right side, into Action Description type “Reset-To-Home”. 

 On the right side, change the dropdown from Remap to Macro. Click Add. 

 Inside the newly added gray Macro box: 

o In the column of icons, click the top icon. 

o Inside the right side’s Action Settings do the following: 

o Change the dropdown from Pause to vJoy. 

o Below the new dropdown vJoy Device 1, change the blank dropdown to Y Axis (vJoy Axis 2). 

o Leave the Absolute button checked, not the Relative one. 

o Arrow up to the value: 1.000. 

 At right, click on the sideways tab Condition.  

Change the Apply conditions to dropdown to Container.  

At right, change the dropdown to from Keyboard Condition to Action Condition. Click Add.  

In the new Action Condition box, leave the dropdown as Pressed. 

 Back to the main top level (still on right side panel), the dropdown should still read as Macro. Click Add 

to add another macro.  

A new Macro box appears below the first Macro box. Scroll down. 

 Inside the second Macro: 

o In the column of icons, click the top icon. 

o Inside the right side’s Action Settings do the following: 

o Change the dropdown from Pause to vJoy. 

o Below the new dropdown vJoy Device 1, change the blank dropdown to Y Axis (vJoy Axis 2). 

o Leave the Absolute button checked, not the Relative one. 

o Leave the value as: 0.000. 

 At right, click on the sideways tab Condition.  

Change the Apply conditions to dropdown to Container.  

At right, change the dropdown from Keyboard Condition to Action Condition. Click Add.  

In the new Action Condition box, change the dropdown from Pressed to Released. 



Map the Flight Modes Buttons to vJoy Axis 1 

 Press the Button 2 near the top of the joystick. The left side’s highlight jumps to Button 2. 

 On the right side, into Action Description type “Flight Modes - Low”. 

 On the right side, change the dropdown from Remap to Macro. Click Add. 

 Inside the newly added gray Macro box: 

o In the column of icons, click the top icon. 

o Inside the right side’s Action Settings do the following: 

o Change the dropdown from Pause to vJoy. 

o Below the new dropdown vJoy Device 1, change the blank dropdown to X Axis (vJoy Axis 1). 

o Leave the Absolute button checked, not the Relative one. 

o Arrow down to the value: -1.000. 

 Press Button 8 at the base of the joystick. The left side’s highlight jumps to Button 8. 

 On the right side, into Action Description type “Flight Modes - Medium”. 

 On the right side, change the dropdown from Remap to Macro. Click Add. 

 Inside the newly added gray Macro box: 

o In the column of icons, click the top icon. 

o Inside the right side’s Action Settings do the following: 

o Change the dropdown from Pause to vJoy. 

o Below the new dropdown vJoy Device 1, change the blank dropdown to X Axis (vJoy Axis 1). 

o Leave the Absolute button checked, not the Relative one. 

o Leave the value as: 0.000. 

 Press the “Hat” button at the top of the joystick. The left side’s highlight jumps to Hat 1. 

 On the right side, into Action Description type “Flight Modes - High”. 

 On the right side, change the dropdown from Remap to Macro. Click Add. 

 Inside the newly added gray Macro box: 

o In the column of icons, click the top icon. 

o Inside the right side’s Action Settings do the following: 

o Change the dropdown from Pause to vJoy. 

o Below the new dropdown vJoy Device 1, change the blank dropdown to X Axis (vJoy Axis 1). 

o Leave the Absolute button checked, not the Relative one. 

o Arrow up to the value: +1.000. 

o At right, change from the sideways Action tab to the Virtual Button tab. 

o Click all virtual button boxes. 

Save Your Work 

 From the menu, File -> Save Profile As and give it a name, e.g. Sidewinder.xml .  

After you have saved it once, you can File -> Save Profile at any time, of course. 

Activate and Test 

When the JG gamepad icon is green, the JG-viewer window should show all vJoy axes reacting to your controls 

defined above (see table at the beginning of the setup guide). 

  



Confirm the Remapping 

Finally, your controller inputs should match the standard axes order below which also shows the axis directions 

(via showing full control throws in the specific directions). The mapping order, generally, was discussed here. 

In this diagram, the “Axis 1” for vJoy is “1. Flight Modes” (“FM”) for SeligSIM, etc. 

When you finish this guide, return back to the last part of Getting Started: Part I to continue your setup and run 

SeligSIM. 

 
Standard axes order in SeligSIM with sliders at full deflections for the controls indicated. 

https://www.seligsim.com/manual/getting_started.html#final-channel-ordering
https://www.seligsim.com/manual/getting_started.html#final-channel-ordering
https://www.seligsim.com/manual/controllers/_images/gremlin/standard-15-1118p.jpg

